Support    SuperLab    Interfacing With National Instruments Devices

The requirements described below apply only if you want to use SuperLab 4 or later with a National Instruments I/O device.

SuperLab for Windows

SuperLab for Windows requires that the following National Instruments library be installed: NI-DAQmx 8.5 or later. It may work with earlier versions of NI-DAQmx, but it has been tested with versions 8.5 and 8.8.

SuperLab for Mac – version 4.5 or Later

Version 4.5 of SuperLab for Mac:

  • If you are using Mac OS 10.4 Tiger, 10.5 Leopard, or 10.6 Snow Leopard, the following National Instruments library must be installed: NI-DAQmx Base 3.4.0. Other 3.x versions of NI-DAQmx Base may work, but version 3.4.0 is what we tested SuperLab 4.5 with. Earlier versions 2.x of NI-DAQmx Base will not work with SuperLab 4.5.
  • If you are using Mac OS 10.7 Lion, you must install NI-DAQmx Base 3.5.0 or later; earlier versions are not compatible with Lion.
  • Although SuperLab 4.5 is still compatible with PowerPC-based Macs, NI-DAQmx Base 3.4.0 is not. Therefore, using a National Instruments device with SuperLab 4.5 is possible only on Intel-based Macs.

Last Revision: April 5, 2012

Products

Other Links

Stay in Touch

© Copyright 2017 Cedrus Corporation, P.O. Box 6309, San Pedro, CA 90734 - USA

Toll Free: (800) 233-7871, other (310) 548-9595. Send us an email. See privacy policy.